Why you should update your app today


Previous versions of the Racing Post app will soon stop working. The following out of date Android or IOS operating systems will no longer be supported and will need to be updated.

Android version lower than 21.1

IOS lower than 21.1.

Making sure you are using the latest version of the app also ensures you'll enjoy the fastest and most reliable experience with the latest new features and more.

We continue to improve our app fixing any bugs and improving or adding features. We recommend you review the version you are currently using immediately. 

Can't find what you're looking for?

Contact us View all articles